Interface > Interface til varme systemer

API til adurocloud / Aduro Hybrid

(1/5) > >>

Hej !
Jeg er ny ejer af en Aduro Hybridovn - og er samtidig ihærdig bruger/udvikler på smarthome-løsninger.
Er der nogen der ved om det er muligt at udlæse data fra - samt evt. styre - aduro-hybrid-ovnen vha. http/mqtt eller lign. ?
Jeg er med på at jeg kan logge mig på og se min ovns data - men har brug for et simpelt API til at kode mod...
Gode ideer imødeses gerne ;-)


The aduro hybrid apparently uses mostly the same protocol as scotte V7/13, so you can use to read and write from/to it. (See )

Pellmon with the NBEcom plugin should then also work, and with that running you can use pellmonMQTT to connect pellmon to an mqtt broker and there you have it...

the 'nbetest' client is crossplatform, pellmon and pellmonmqtt only linux (but you can run in in a virtual machine).

Or you can use NBEtest as 'documentation' to code up your own protocol client in your preferred language. Some info here also:

Hope this helps!

Fantastic - it works !! - I just managed to start and then stop my Aduro H2 using the nbetest script etc.
I will now start exploring how to embed this in my smarthome setup (OpenHab) - probably through PellMon which I have yet to try out
Thanks a million !

Hmm - I ran into a problem getting Pellmon to work - installation on my raspberry pi went fine - and configs are all set. However, NBECom does not connect to my Aduro H2.
I dont seem to be able to find any config where I can set the IP address of my Aduro for Pellmon to look for it ? - it says it will "autodiscover" but that does not seem to work.
When trying out NBETEST as you suggested, I simply used the -a parameter and inserted the local IP (in my case of my Aduro. That worked fine...
Any suggestions ?

Hello greatdane. Great that it works, so far...

PellMon only supports autodiscovery. You probably already set your serial number and password in /etc/pellmon/conf.d/plugins/nbecom.conf?
And did you install the newest alpha3 release or 0.7.0? There was some problems with V13, I think I made some small fix for that a year or so ago. V13 back then at least tripped out if you tried to connect with a port > 9999. Since aduro is new it probably is more similar to V13 than V7, so I think you need the latest alpha. There might be other issues also, you are the first that I know of to try out PellMon with aduro... Pellmon might very well misbehave if the aduro doesn't have all the data that a 'normal' V13 has, but I'm sure we can sort that out if you can help out a bit, since nbetest is already working.


[0] Emneindeks

[#] Næste side

Skift til fuld version